Posts tagged ‘Flash Player Flaws’

Adobe Released the First Package for Flash Player Flaws in 2013

Will the evolution of Adobe Flash Player be dominated by system flaws and security updates in 2013? Currently speaking, there is a great chance that vulnerabilities will once more set the main tunes for Adobe Flash Player in 2013. Just a few hours ago, Adobe has released the first package for Flash Player flaws in 2013 in an attempt to protect customers from being attacked by a system vulnerability identified as APSB13-01. This time, instead of providing detailed information about the system vulnerability, Adobe only describes it as something that may cause a crash or provide hackers the chance to control the computer.

According to the bug-fixing plan provided on the second Tuesday in 2013, Windows users using version 11.5.502.135 or below shall update to 11.5.502.146; Mac users with version 11.5.502.136 shall update to 11.5.502.146 and Linux users with version 11.2.202.258 shall update to 11.2.202.261. Moreover, even though Adobe Flash Player had retreated from Android market, this update has also offered promised package for Flash Player flaws to Android users. Of course, the package is theoretically patched to users who had installed Flash Player on Android devices before August 15, 2012. ICS device is advised to install Adobe Flash Player 11.1.115.36 and device running system below android 4.0 to install Adobe Flash Player 11.1.111.31.

First Update about Flash Player in 2013

Even though the first package for Flash Player flaws is patched for almost all platforms, it is not accessible for both Chrome users and IE 10 users. Given the fact the vulnerable Adobe Flash Player frequently brings troubles to system security, both web browsers are reluctant to add full support to the application. As a consequence, Adobe Flash Player is either sandboxed in Chrome or used as a plugin for IE 10. The only way for Chrome users and IE 10 users to update Adobe Flash Player is to wait for the update from Google and Microsoft respectively.   

What makes Adobe Flash Player so vulnerable and fragile? For one thing, Adobe Flash Player is a close application not that perfect in design. This provides a chance for hackers to take full advantage of its potential design flaws. For another, Adobe Flash Player is a popular cross-platform application that poses great influences on Internet fields like video streaming and online gaming. As a consequence, it has been the target for most hackers for a long time.

In fact, in the latest package for Adobe Flash Player flaws, Adobe also provides the priority ratings of the package for different platforms. The ratings are generally made in accordance with the popularity rankings of the operating systems for PC. Windows, with over 90% market share in PC market, gets top priority, followed by Macintosh with 7% market share. With the least market share, Linux only gets lowest priority ratings from Adobe in the three mainstream systems.